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Navigation 

 Folders  One or several root folders are available. They look like a folder tree in the left area. Use the 

Folders button in the toolbar to show or hide the tree of the root folders.  

 List  There is a list of content of the current folder in the right interface area. You may go to the 

subfolders or the parent folders by double-clicking.  

 File choice  You may choose one or several files or folders by clicking on the items and using Ctrl 

and Shift or all the items with the help of the menu.  

 Menu  Context menu can be seen by right-clicking with your mouse or clicking on the File button in 

the toolbar.  

Main files operations 

You can do basic file operations: 

create, copy, edit, cut, delete, rename, preview, zip and unzip.  

Files upload and download 

 Upload 

Depending on the application settings, you may use several ways to upload files:  

 Standard — upload files one by one using the Browse button. Note! Latest browsers like Firefox, 

Chrome, Internet Explorer supports multiple file upload! 

 Drag'n'Drop — if you using latest browser versions, you can add and upload files with help of 

drag'n'drop function. 

 Java — select multiple files and folders at the same time. 

 Flash — select and upload multiple files at the same time. 

 Silverlight — select and upload multiple files at the same time by chunks (it helps to upload 

files that are more than 2GB). It supports drag-n-drop function. 

 Google Drive — files uploading from your  Google Drive account. 

 Dropbox — files uploading from your  Dropbox account. 

https://drive.google.com/
https://www.dropbox.com/


 Microsoft OneDrive — files uploading from your  OneDrive account. 

 Box — files uploading from your  Box account. 

 Upload from URL — you can specify a URL of a file stored at a global file server or at a file 

sharing services like  Dropbox,  Picasa,  Flickr,  PhotoBucket,  Facebook. 

Note. You can use a ZIP archive to upload multiple files and then extract it on the server side, using 

 Unpack Zip in context menu.  

 Download 

Select one or multiple files and folders and click the button  Download (in the menu to download 

them). Depending on the settings you may download the files one by one or use the Java downloader 

to download multiple files and folders.  

There are some other ways to download files:  

  Compress and download — option in the menu for automatic compression of the selected 

files and their downloading in a zip archive. 

  Cloud storages → dowload to...  Google Drive,  Dropbox,  OneDrive, 

 Box — files/folders downloading to your Cloud storages accounts.  

 Links to files and folders 

It allows you to download a file quickly without opening the main interface or to open a folder. Choose 

Share submenu in context menu (or in toolbar) and next item  Link to file/folder. Notice that 

other users should log in and have an access to the folder. Otherwise they will get an error.   

 Sharing files, folders for your own visitors 

You can create your own shares i.e provide access to your folder/file for your own visitors. Select needed 

folder/file and click from the context menu Share (or find this item on toolbar) and next item 

 Create public link. This feature provides anonymous access to the folder/file. Any user, even one 

who does not have an account in the web file manager, may download or upload files via public link. 

Public link to the folder allows the user to download both whole folders (packed in archive) and individual 

files. You can get set up email notifications to be notified about visitor activity.  

 Link to Web Folders (folder mapping) 

Web folders makes it possible to map the folders to your local OS using 

WebDAV protocol. You may work with your files like with local ones. You do not need a browser for work 

or to log in every time. You just need to open a folder that you map in OS. (in Microsoft Windows – in 

Windows explorer). Popular OS Windows, MacOS, Ubuntu, etc. support mapping web folder. 

It is very easy to map web folder:  

https://onedrive.live.com/
https://app.box.com/files/
https://www.dropbox.com/
http://picasa.google.com/
https://www.flickr.com/
http://www.photobucket.com/
https://www.facebook.com/
http://en.wikipedia.org/wiki/WebDAV


 Select needed folder; in context menu choose submenu  more (or click this button in toolbar) 

and next  Map web folder. 

 If you using Microsoft Windows, then copy the one from the command connection the command 

line Windows (can be accessed up to three teams: the current folder, the parent and root). For 

example: net use "*" "http://example.com/htcomnet/hcwebdav/". Next click OK and if 

needed input your login and password. 

 Also for Windows OSs available other way to connect. Copy link for mapping. Right click on 

Computer in Windows Explorer (or This Computer for Windows 8, 8.1) and select Add a 

network location. In the new dialog Add Network Location click Next button. Select 

"Choose a custom network location" and click Next button. Insert the link of the web folder 

in the "Internet or Network address" field, click "Next". 

Note! It is strongly recommended for Windows 7, Vista, XP, 2003 users to install Microsoft 

Web folders update (2.3 Mb) to be able to use mapping feature! 

 For MacOS: In the "Finder" menu, open Go->Connect to Server, insert the link of the web 

folder in the "Server address" field, click "Connect", in the new dialog select "Guest" or 

"Registered user" (for Windows authentication), click "Connect". 

 For Ubuntu: Open Go->Location... Copy the link of the web folder to the location field and 
repace "http://" with "dav://" or "https://" with "davs://". 

After you have mapped a web folder, you may open it without visiting the web site next time. Note! If 

you change your password, the directory to the web folder will be changed and you need to map it again 

(except Windows authentication cases).  

See also: 

Using the WebDAV Redirector with OneDrive Part 1 - Standard Security 
Using the WebDAV Redirector with OneDrive Part 2 - Two-Step Verification  

 Details 

You may specify comments, descriptions or other metadata for files and folders by clicking  Details in 

the menu. 

Note! Details are saved if files are copied, moved or renamed.  

Office and images files view and edit 

Web File Manager has a lot of functions to work with office documents.  

Documents view 

Text and PDF documents, image files, you can view directly in your browser, selecting  View / edit → 

 View in browser in context menu or toolbar.  

If folder contains image files, then view them as a slide show, you can use the opportunity to  View / 

edit →  Images preview, or switch the view file list in the thumbnail view (button on toolbar 

 View →  Thumbnail view).  

In addition, you can use online services  Google Docs,  Microsoft Office Web Viewer,  Box 

View to view documents in various formats.  

To do this, select the file, click on the menu (or toolbar)  View / edit desired item (if it is allowed by 

the administrator). Next link will be created by clicking on which you can view the file.  

Supported formats in Google Docs: pdf, doc, docx, ppt, pptx, tif, tiff, xls, xlsx, pages, ai, psd, svg, eps, 

http://www.microsoft.com/downloads/en/details.aspx?FamilyId=17C36612-632E-4C04-9382-987622ED1D64&displaylang=en
http://www.microsoft.com/downloads/en/details.aspx?FamilyId=17C36612-632E-4C04-9382-987622ED1D64&displaylang=en
http://blogs.iis.net/robert_mcmurray/using-the-webdav-redirector-with-onedrive-part-1-standard-security
http://blogs.iis.net/robert_mcmurray/using-the-webdav-redirector-with-onedrive-part-2-two-step-verification
https://docs.google.com/gview
http://office.microsoft.com/en-us/online/view-office-documents-online-FX102727753.aspx
https://developers.box.com/view-api/
https://developers.box.com/view-api/
https://docs.google.com/gview
http://office.microsoft.com/en-us/online/view-office-documents-online-FX102727753.aspx
https://developers.box.com/view-api/


ps, xps, ttf, zip, rar, dxf, txt, css, html, htm, php, c, cpp, h, hpp, js.  
Supported formats in Microsoft Office Web Viewer: doc, docx, docm, dotm, dotx, xls, xlsx, xlsb, xlsm, 
pptx, ppsx, ppt, pps, pptm, potm, ppam, potx, ppsm (Word and PowerPoint documents must be less than 

10 megabytes; Excel must be less than 5 megabytes).  

Supported formats in Box View: pdf, doc, docx, ppt, pptx, xls, xlsx, txt, py, js, xml, css, md, pl, c, m, 
json.  

Also you can convert various types of files with  CloudConvert service (  View / edit → 

 Convert with CloudConvert).  

 

Online documents editing 

Small size text documents you can edit by selecting from the context menu (or toolbar) item  View / 

edit →  Edit as text file.  

Also using the service  Zoho Docs you can edit popular office document formats (doc, docx, xls, xlsx, 

ppt, pptx, pps, odt, ods, odp, sxw, sxc, sxi, wpd, rtf, txt, html, csv, tsv), selecting  View / edit → 

 Edit in Zoho.  

Image files (jpg, jpeg, png, gif, bmp, psd, pxd) can be edited using the online service   Pixlr: 

 View / edit →  Edit in Pixlr. In addition to editing, you can create in Pixlr new images using the 

context menu or toolbar command  New →  Image in Pixlr.  

 

Primary means of online editing office documents are applications on your computer  Microsoft 

Office, or free  Apache OpenOffice,  LibreOffice. You do not need to download or upload the 

files. Microsoft Office, OpenOffice, LibreOffice do it automatically. You just need to have these 

applications installed on your local computer.  

How it works:  

1. Select a file of one of the following types. Microsoft Office types: accda, accdb, accdc, accde, 
accdp, accdr, accdt, accdu, ade, adp, maf, mam, maq, mar, mat, mda, mde, mdt, mdw, laccdb, 

snp, csv, dbf, dif, ods, prn, slk, xla, xlam, xls, xlsb, xlsm, xlsx, xlt, xltm, xltx, xlw, xml, xps, obi, 
oft, ost, prf, pst, msg, oab, iaf, emf, odp, pot, potm, potx, ppa, ppam, pps, ppsm, ppsx, ppt, 
pptm, pptx, pptx, rtf, thmx, tif, wmf, xml, xps, doc, docm, docx, dot, dotm, dotx, htm, html, mht, 
mhtml, odt, rtf, txt, wps, xml, xps, btr, dwt, elm, fwp, htx, mso  

or OpenOffice / LibreOffice types: sxd, sxm, sxi, sxc, sxw, odb, odf, odt, ott, oth, and, odm, 
sxw, stw, sxg, doc, dot, xml, docx, docm, dotx, dotm, wpd, wps, rtf, txt, csv, sdw, sgl, vor, uot, 
uof, jtd, jtt, hwp, 602, pdb, psw, ods, ots, sxc, stc, xls, xlw, xlt, xlsx, xlsm, xltx, xltm, xlsb, wk1, 
wks, 123, dif, csv, sdc, vor, dbf, slk, uos, uof, pxl, wb2, odp, odg, std, otp, otg, sxi, sti, ppt, pps, 
pot, pptx, pptm, potx, potm, ppsx, sda, sdd, sdp, vor, uop, uof, cgm, bmp, jpeg, jpg, pcx, psd, 
sgv, wmf, dxf, met, pgm, ras, svm, xbm, emf, pbm, plt, sda, tga, xpm, eps, pcd, png, sdd, tif, 

tiff, gif, pct, ppm, sgf, vor, mml. 

2. Select in menu  View / edit one of commands  Edit in MS Office or  Edit in 

OpenOffice / LibreOffice. The relevant application will launch with the selected files opened 

for editing. If for some reason the application has not launched, copy the link to the file and open 

it in Microsoft Office, LibreOffice or OpenOffice. 

3. To save the changes in the document, press Сtrl+S combination or click on the Save in the File 

menu of Microsoft Office, LibreOffice or OpenOffice. The document will be saved and uploaded to 
server automatically. 

Features and settings of Microsoft office: 

https://cloudconvert.com/
http://www.zoho.com/docs/zoho-docs-features.html#zohoonlineeditors
https://pixlr.com/
http://office.microsoft.com/
http://office.microsoft.com/
http://www.openoffice.org/
http://www.libreoffice.org/
https://cloudconvert.com/
http://www.zoho.com/docs/zoho-docs-features.html#zohoonlineeditors
https://pixlr.com/
http://office.microsoft.com/
http://www.openoffice.org/
http://www.libreoffice.org/


 Microsoft Office by default does not work with Basic authentication without SSL (does not 

allow the user to read a document or open it in read only mode). If you got a message that the 

application is running under Basic authentication without SSL then you can make a fix in the 

registry key. After that, Office will work. 

Complete the following steps (for more info, read Microsoft related article):  

o Vista and Windows 7, 8 users need to download the file BasicAuthVista7Set.reg and run 

it (To return default settings run BasicAuthVista7Remove.reg ) 

o Windows XP and 2003 Server users need to download the file BasicAuthXP2k3Set.reg 

and run it (to return default settings run BasicAuthXP2k3Remove.reg ) 

o Restart Windows 

 Note! It is strongly recommended for Windows 7, Vista, XP, 2003 users to install Microsoft 

Web folders update (2.3 Mb) to be able to use this feature! 

 Microsoft Office supports file lock for prohibiting simultaneous file editing by several users. If a 

file has been blocked by another user, you cannot edit the file, but you can read it and you will 

get a notification from MS Office as soon as the file is available.  

 By default Microsoft office blocks the document for editing. After you enable editing of a file, it 

will be downloaded from server again. To increase the efficiency, you may enable immediate 

editing in settings: In Microsoft Office menu select File → Options → Trust Center → Trust 

Center Settings...(button) → Protected View uncheck Enable Protected View for files 

originating from the Internet. 

 Microsoft office 2010 does not support file links with more than 255 symbols, so try to use short 
file names with ASCII characters. 

Features and settings of OpenOffice / LibreOffice: 

This is a free application that is available for many OS on the websites OpenOffice, LibreOffice. At the 

moment OpenOffice and LibreOffice does not support file lock, so be aware if there are users 

simultaneously working with documents. OpenOffice is planning to add this functionality in 3.4 version. 

OpenOffice and LibreOffice application uses Java applet for launch. If you do not want to allow the 

applet, you may get a file link and open this file in the OpenOffice / LibreOffice Open dialogue.  

Recommended settings for OpenOffice, LibreOffice: 

1. If you don't want to type the login and password every time, you may enable OpenOffice / 

LibreOffice Quickstarter that saves information about a user: Open Tools → Options → 

OpenOffice (LibreOffice) → Memory, check Load OpenOffice (LibreOffice) during 

system start-up. 

2. To save the files opened via links (without Java applet), you need to enable it in settings: Go to 

Tools → Options → OpenOffice (LibreOffice), check Use OpenOffice (LibreOffice) 
dialogs. 

 Cloud storages 

In context menu or toolbar is available (depending on settings) menu  Cloud storages, which allows 

you to interact (upload and download files, folders) with popular cloud services storage:  Google 

Drive,  Dropbox,  Microsoft OneDrive,  Box.  

 Upload/Download documents to Google Drive (online documents edit and 
sharing) 

http://support.microsoft.com/kb/2123563
https://www.element-it.com/download/httpcommander/BasicAuthVista7Set.reg
https://www.element-it.com/download/httpcommander/BasicAuthVista7Remove.reg
https://www.element-it.com/download/httpcommander/BasicAuthXP2k3Set.reg
https://www.element-it.com/download/httpcommander/BasicAuthXP2k3Remove.reg
http://www.microsoft.com/downloads/en/details.aspx?FamilyId=17C36612-632E-4C04-9382-987622ED1D64&displaylang=en
http://www.microsoft.com/downloads/en/details.aspx?FamilyId=17C36612-632E-4C04-9382-987622ED1D64&displaylang=en
http://www.openoffice.org/
http://www.libreoffice.org/
https://drive.google.com/
https://drive.google.com/
https://www.dropbox.com/
https://onedrive.live.com/
https://app.box.com/
https://drive.google.com/
https://www.dropbox.com/
https://onedrive.live.com/
https://app.box.com/


You can download documents to your Google Drive account (  Cloud storages →  dowload to... 

→  Google Drive) or upload them back (  Cloud storages →  upload from... →  Google 

Drive). After download you can modify the document using only your browser and then upload the 

modified document back to the web file manager. Authentication is passed at Google site so nobody 

wont get your password.  

 Dropbox — free online backup, file sync and sharing. 

To download file to your Dropbox account select files, folders and then choose (in menu or toolbar) 

 Cloud storages →  download to... →  Dropbox. To upload —  Cloud storages → 

 upload from... →  Dropbox. Authentication is passed at Dropbox site so nobody will get your 

password.  

 Microsoft OneDrive 

You can create an account at a free online files, documents edit and sharing service  Microsoft 

OneDrive (if you already have Microsoft Live ID then you dont need to register at OneDrive!). With web 

file manager you can download files, folders to your OneDrive account (  Cloud storages → 

 dowload to... →  Microsoft OneDrive) or upload from it (  Cloud storages →  upload 

from... →  Microsoft OneDrive). At the OneDrive website you can edit your documents and share 

files for other users.  

 Box — free online backup, file sync and sharing cloud service 

For download to Box select files, folders and use command  Cloud storages →  download to... 

→  Box. To upload —  Cloud storages →  upload from... →  Box.  

 Hyperlinks 

Web file manager allows you to add hyper links to the list of files. They are represented with small .url 
files.  

Opening a hyper link is a two step process. First, click on the .url file to open a window with the hyper 
link. Second, click on the hyper link to open the URL in a new browser window (or in a tab).  

Screenshot  

To create a hyper link file, you need Internet Explorer.  

 Open the target web page in Internet Explorer. 

 Open main menu (press F10 if it is not visible) → File → Send → Shortcut to Desktop. 

 A conformation dialog appears. Click "yes" to confirm that you want to create a shortcut on 

desktop. 

Screenshot  
 Upload the shortcut file to Web file manager. 

You may change name of the file, but do not touch the extension.  

https://signup.live.com/signup.aspx
https://signup.live.com/signup.aspx
../../Images/HyperLink.png
../../Images/CreateShortcutConformation.png
https://signup.live.com/signup.aspx


.url files are standard Windows ini files with custom extension. You may create them in a text editor if 
you do not have Internet Explorer or you do not want to use it.  

Mobile view       

You can view a 100% mobile interface on your device: Click Settings → Mobile interface or type 
"Default.aspx?Mobile=" URL in your mobile browser.  

Application supports: iPhone/iPad, Android-based, Blackberry v.6+, Bada, Windows Mobile, 
Phone and some other mobile device OS's.  

You can also download a mobile application for your iPhone/iPad at http://itunes.apple.com/us/app/http-

commander/id561413475?mt=8 and for Android at 
https://play.google.com/store/apps/details?id=com.elementit.httpcommander.  

For more info about the mobile version see Mobile users Help  

 Settings 

Click  Settings options in the toolbar and select necessary type of settings. In the resulting menu, use 

the following settings:  

  Change interface language. 

  Change password. 

  Change e-mail. 

  Switch to mobile interface (the option can be prohibited by administrator). 

 

 

http://en.wikipedia.org/wiki/INI_file
http://itunes.apple.com/us/app/http-commander/id561413475?mt=8
http://itunes.apple.com/us/app/http-commander/id561413475?mt=8
https://play.google.com/store/apps/details?id=com.elementit.httpcommander
MobileHelp.html
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